$re = '/<%image\((.*)\|.*\|.*\|\)%>/';
$str = '<%image(20100213-na-de-les-mag-hij-even-blijven.jpg|120|120|)%>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);