#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msi)(<script.*?>.*?<\/script>)"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html lang="en">" & @CRLF & _
"<head>" & @CRLF & _
" <meta charset="UTF-8">" & @CRLF & _
" <title>Document</title>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
" <p>Lorem ipsum dolor sit amet, consectetur adipisicing elit. Nisi, modi.</p>" & @CRLF & _
" <script async type="text/javascript" src="jquery-1.10.2.min.js"></script>" & @CRLF & _
" <script type="text/javascript" src="effects.js" async></script>" & @CRLF & _
" <script async>" & @CRLF & _
" void 0;" & @CRLF & _
" </script>" & @CRLF & _
" <!-- все скрипты , что выше не должны попасть в выборку -->" & @CRLF & _
" <script type="text/javascript" src="prototype.js" ></script>" & @CRLF & _
" <script type="text/javascript" src="dragdrop.js"></script>" & @CRLF & _
" <script type="text/javascript" src="controls.js"></script>" & @CRLF & _
" <script type="text/javascript" src="slider.js"></script>" & @CRLF & _
"" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
" void 0;" & @CRLF & _
" async_function();" & @CRLF & _
" </script>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")