re = /(?:semlps\/totalsource|sem-totalsource\/2017)(?:\/)?(?:.*[^0-9a-zA-Z].*)?(?:\\.aspx)?$/mi
str = 'https://adp-iat.adp.com/sem-totalsource/2017/learnmorehro.aspx
https://adp-iat.adp.com/sem-totalsource/2017/learnmorehro-ty.aspx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end