import re
regex = re.compile(r"(\+?(?:(84|0))(\s?[\-\u2010\u2011\u2012\u2013\u2014\u2015]?\s?)[357-9]\d{6}(?:\d{2}(?:\d{1})?)?)", flags=re.MULTILINE)
test_str = ("1234567\n"
"76543211234\n"
"123456789\n"
"12345778\n"
"1234567890\n"
"+8412345678\n"
"84123456789\n"
"8412345\n"
"84123456\n"
"+1234567\n"
"+84\n\n"
"0123456\n\n"
"+84356763987\n"
"5123456\n"
"31234567\n"
"712345678\n"
"9123456789\n"
"+84-5123456\n"
"+84 5123456\n"
"05123456\n"
"0-5123456\n"
"+84 - 5123456\n"
"843378262\n"
"84337671542\n"
"84575516147\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")