# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|\G(?!^))(\w+),?\h(?=.*##(.+)$)/$2|$1##/gm;t' <<< "quirky, stable, fun ##Paul and Jill
mean, rude, sad, other ##Dave
rich, foolish ##Amanda"