use strict;
my $str = 'quirky, stable, fun ##Paul and Jill
mean, rude, sad, other ##Dave
rich, foolish ##Amanda';
my $regex = qr/(?:^|\G(?!^))(\w+),?\h(?=.*##(.+)$)/mp;
my $subst = '$2|$1##';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";