re = /(?:^|\G(?!^))(\w+),?\h(?=.*##(.+)$)/m
str = 'quirky, stable, fun ##Paul and Jill
mean, rude, sad, other ##Dave
rich, foolish ##Amanda'
subst = '$2|$1##'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result