#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\.[^.\n]+$"
Local $sString = "Hello.jpg" & @CRLF & _
" (ok)" & @CRLF & _
"Goodbye.mp4" & @CRLF & _
" (ok)" & @CRLF & _
"Free.xlsx" & @CRLF & _
" (ok)" & @CRLF & _
"GettingStarted" & @CRLF & _
" (NO)" & @CRLF & _
"File.81723.domain.8080.pdf" & @CRLF & _
" (ok)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")