package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^https?:\/\/[w\d.]*([\S][^\/]+)`)
var str = `https://www.google.es/?gfe_rd=cr&ei=T5n6Va_qCdSp8wfljLSADg&gws_rd=ssl#q=generic+search`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}