const regex = /^https?:\/\/[w\d.]*([\S][^\/]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/[w\\d.]*([\\S][^\\\/]+)', '')
const str = `https://www.google.es/?gfe_rd=cr&ei=T5n6Va_qCdSp8wfljLSADg&gws_rd=ssl#q=generic+search`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}