re = /^https?:\/\/[w\d.]*([\S][^\/]+)/
str = 'https://www.google.es/?gfe_rd=cr&ei=T5n6Va_qCdSp8wfljLSADg&gws_rd=ssl#q=generic+search'
# Print the match result
str.match(re) do |match|
puts match.to_s
end