#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\/[0-9]*)?)?(,([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\/[0-9]*)?)?)*"
Local $sString = "1-2/9,2-3/33,5,6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")