package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\/[0-9]*)?)?(,([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\/[0-9]*)?)?)*`)
var str = `1-2/9,2-3/33,5,6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}