import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\\/[0-9]*)?)?(,([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\\/[0-9]*)?)?)*";
final String string = "1-2/9,2-3/33,5,6";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}