// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\/[0-9]*)?)?(,([01]?[0-9]|2[0-3])(-([01]?[0-9]|2[0-3])(\/[0-9]*)?)?)*").unwrap();
let string = "1-2/9,2-3/33,5,6";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}