package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^)(?:[^d][^e][^f])+\(`)
var str = `def a(self)
def ab(self)
def abc(self)
def abcd(self)
a(self)
ab(self)
abc(self)
abcd(self)
It should not match lines with:
anything def anything(thing)
And only match lines as:
anything anything(thing)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}