$re = '/[[:lower:]][[:upper:]]|\B[[:upper:]][[:lower:]]/';
$str = 'PleaseMatch this
And alsoThis
this ASWell
thisTOO
1Aa
A1Aa
a1Aa
a1A
Though NOT THIS
Nor This
Foo_Bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);