re = /[[:lower:]][[:upper:]]|\B[[:upper:]][[:lower:]]/
str = 'PleaseMatch this
And alsoThis
this ASWell
thisTOO
1Aa
A1Aa
a1Aa
a1A
Though NOT THIS
Nor This
Foo_Bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end