const regex = /\['.*?',\s*(.*?)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\'.*?\',\\s*(.*?)\\]', 'gm')
const str = `['WRK', 'SOCCER', 'CHILD']
['FIN', 'TENNIS', 'CHILD']
['WRK', 'GOLF', 'CHILD']`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);