package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]{5,8}_\d{1,2})\.jpg`)
var str = `aaaaa_11.jpg
aaaaa_11.jpeg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}