use strict;
my $str = 'PoE Port Info\',\'1 up medium Auto Class Searching 0 0.0 0 0.0\',\'10 up low User defined 4(W) Searching - 0.0 0 0.0
10 up low User defined 4(W) Searching - 0.0 0 0.0
';
my $regex = qr/[^\S\r\n]{2,}/mp;
my $subst = '|||';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";