$re = '/(?<=^|abc)(?:(?!abc).)+/m';
$str = 'abbacaba
ddabcdd
ddabcddddabcdd
ddabcddddabc
abcddddabcdd
ddabcabcddddabcdd
abcabcddddabcdd
ddabcabcddddabcabc
ddabcabcabddddabcdd
abcabcabddddabcdd
ddabcabcddddabcabcab
ddabcababcddddabcabcab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);