import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[-]?\\d*\\.\\d+|[-]?\\d+";
final String string = "This is number extract test.\n"
+ "There are 3 types of numbers here.\n"
+ "First type is integer: like 345 or -343.\n"
+ "Second is float like 12.3, 15.329 or -34.2.\n"
+ "Third is portion like .342 or -.532.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}