const regex = new RegExp('(?<=[^\\w\\s])\\s+', 'gm')
const str = `hello there, how are you doing?
Hi! I got a new product for you. Would you like to know more?
It's Taco Tuesday man`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}