$re = '/(?<=[^\w\s])\s+/m';
$str = 'hello there, how are you doing?
Hi! I got a new product for you. Would you like to know more?
It\'s Taco Tuesday man';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);