re = /(?<=[^\w\s])\s+/m
str = 'hello there, how are you doing?
Hi! I got a new product for you. Would you like to know more?
It\'s Taco Tuesday man'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end