// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\['key_to_search_for'\]\['post_date'\] = '(\d{1,2} \w+ \w+)';$").unwrap();
let string = "['key_to_search_for']['post_date'] = '10 days ago';
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}