$re = '/tchumim(\W*\w*){1,5}com/m';
$str = 'https://tchumim.com/post/10185
RegexInWord exe tchumim com
tchumim RegexInWord exe
com
tchumim RegexInWord exe RegexInWord exe RegexInWord exe com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);