$re = '/\b\D{5}\d{4}\D\b/m';
$str = 'pan number : ASDFG4356P
pan number : WERTSDFG4356P
pan number : DFG4356P
pan number : ASDFG4356PRTE
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);