#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^([\S]+)([ ])([\S]+)([ ])([\w\d]+)|^(.*)|^(.*)(.*))"
Local $sString = "asfdf as fsad f sa" & @CRLF & _
"fma9 j23489 rz2398 rz23 97úú" & @CRLF & _
"va h89 3zr1q e 3pőü1 ru3" & @CRLF & _
"39öa4ghaö8zaígvnydpvjydöi fuwa89ö fuaw sdf sad sd sdf sd fa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")