using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^()]*\)(*SKIP)(*FAIL)|;";
string input = @"abcd;ghi;dfsF(adffg;adfsasdf);dfg;(asd;fdsg);ag
zvc;dfasdf;asdga;asd(asd;hsfd)
adsg;(asdg;ASF;DFG;ASDF;);sdafdf
asagf;(fafgf;sadg;sdag;a;gddfg;fd)gsfg;sdfa
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}