$re = '/(?:\A|>)(?=([a-c]*<\w+>[a-c]*))/m';
$str = '<foo>abcaaa<bar>a<foo>cbacba<foo>c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);