re = /(?:\A|>)(?=([a-c]*<\w+>[a-c]*))/m
str = '<foo>abcaaa<bar>a<foo>cbacba<foo>c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end