$re = '/^[1-9]\d*(\,[1-9]\d*)*$/m';
$str = '1,2,3,4,5
,1,2,3,4
10,2,3,4,5
01,2,3,4,5
1,02,3,4,5
1,2,3,4,5,
1,,02,3,4
01
01,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);