package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*\.[a-z]+\/?(?:[\w]+(?:\/[\w]+)*)*)`)
var str = `http://stackoverflow.co.th
http://stackoverflow.com
http://stackoverflow.co.th/
http://stackoverflow.com/
http://stackoverflow.com/a/
http://stackoverflow.com/questions/
http://stackoverflow.com/questions/12345
http://stackoverflow.com/12345/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}