const regex = /[\+\*!,\.-a-zA-Z0-9_\s&\w]* Copyright (©|\(C\)) \d{4} COMPANYNAME [&a-zA-Z0-9_\s,\.]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\+\\*!,\\.-a-zA-Z0-9_\\s&\\w]* Copyright (©|\\(C\\)) \\d{4} COMPANYNAME [&a-zA-Z0-9_\\s,\\.]*', 'gm')
const str = `// Copyright © 2019 COMPANYNAME All rights reserved.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}