re = /[\+\*!,\.-a-zA-Z0-9_\s&\w]* Copyright (©|\(C\)) \d{4} COMPANYNAME [&a-zA-Z0-9_\s,\.]*/m
str = '// Copyright © 2019 COMPANYNAME All rights reserved.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end