# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\w+\s#(\d+)/(REF:IN:\1)/u;t' <<< "Incident #00028327 Is now Assigned to Developers Queue"