#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)^\w+\s#(\d+)"
Local $sString = "Incident #00028327 Is now Assigned to Developers Queue"
Local $sSubst = "(REF:IN:\1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)