using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+\s#(\d+)";
string substitution = @"(REF:IN:\1)";
string input = @"Incident #00028327 Is now Assigned to Developers Queue";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}