re = /istio_*/m
str = 'istio_agent_go_gc_duration_seconds{quantile="0"} 7.754e-05
istio___________agent_go_gc_duration_seconds{quantile="0"} 7.754e-05
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end