const regex = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[-+=|,!@#$%&*^?_.~/\\(){}[\]<>])[A-Za-z\d-+=|,!@#$%&*^?_.~/\\(){}[\]<>]{8,}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[a-z])(?=.*[A-Z])(?=.*\\d)(?=.*[-+=|,!@#$%&*^?_.~\/\\\\(){}[\\]<>])[A-Za-z\\d-+=|,!@#$%&*^?_.~\/\\\\(){}[\\]<>]{8,}$', '')
const str = `Test-123@<>*&!~#\$%^&*()__-=+/><.,.>}{}{[]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}