use strict;
my $str = 'qwe';
my $regex = qr/^./p;
my $subst = 'A';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";