#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "from=doggerino@gmail.co(?!\S)"
Local $sString = "from=doggerino@gmail.com sender=yessss" & @CRLF & _
"from=doggerino@gmail.co sender=yessss" & @CRLF & _
"sender=yaaas from=doggerino@gmail.co subject=yaaas" & @CRLF & _
"sender=yaaas from=doggerino@gmail.com subject=yaaas" & @CRLF & _
"sender=yaaas from=doggerino@gmail.com" & @CRLF & _
"sender=yaaas from=doggerino@gmail.co" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")