#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+?\(61\)|\(\+?61\)|\+?61|\(0[1-9]\)|0[1-9])?( ?-?[0-9]){7,9}$"
Local $sString = "+(61) 455 562 400" & @CRLF & _
"" & @CRLF & _
"+61-455-562-400" & @CRLF & _
"+61 455 562 400" & @CRLF & _
"+(61)-455-562-400" & @CRLF & _
"+(61) 455 562 400" & @CRLF & _
"(02) 4371 3164" & @CRLF & _
"(02) 4371-3164" & @CRLF & _
"02 80268989" & @CRLF & _
"03 80268989" & @CRLF & _
"04 80268989" & @CRLF & _
"05 80268989" & @CRLF & _
"433245898" & @CRLF & _
"433 245 898" & @CRLF & _
"433-245-898" & @CRLF & _
"4555-62400" & @CRLF & _
"123456" & @CRLF & _
"08 54 587 456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")