import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+?\\(61\\)|\\(\\+?61\\)|\\+?61|\\(0[1-9]\\)|0[1-9])?( ?-?[0-9]){7,9}$";
final String string = "+(61) 455 562 400\n\n"
+ "+61-455-562-400\n"
+ "+61 455 562 400\n"
+ "+(61)-455-562-400\n"
+ "+(61) 455 562 400\n"
+ "(02) 4371 3164\n"
+ "(02) 4371-3164\n"
+ "02 80268989\n"
+ "03 80268989\n"
+ "04 80268989\n"
+ "05 80268989\n"
+ "433245898\n"
+ "433 245 898\n"
+ "433-245-898\n"
+ "4555-62400\n"
+ "123456\n"
+ "08 54 587 456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}