# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+?\(61\)|\(\+?61\)|\+?61|\(0[1-9]\)|0[1-9])?( ?-?[0-9]){7,9}$"
test_str = ("+(61) 455 562 400\n\n"
"+61-455-562-400\n"
"+61 455 562 400\n"
"+(61)-455-562-400\n"
"+(61) 455 562 400\n"
"(02) 4371 3164\n"
"(02) 4371-3164\n"
"02 80268989\n"
"03 80268989\n"
"04 80268989\n"
"05 80268989\n"
"433245898\n"
"433 245 898\n"
"433-245-898\n"
"4555-62400\n"
"123456\n"
"08 54 587 456")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.