package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^<(?:input)[\s\S]*?({{variable:system_version}})[\s\S]*?>$`)
var str = `<input value="System version: {{variable:system_version}}">
<input value="System version: 6">
<input value="System version: 6">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}