$re = '/(\d)\1+/m';
$str = '111111122325585698888888';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);