#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+?{\s*(.+?)\s*[({]"
Local $sString = "Here are some example of what I'd like to capture:" & @CRLF & _
"" & @CRLF & _
"query SignIn($payload: AuthCredentialsInput!) {" & @CRLF & _
" signIn(payload: $payload) {" & @CRLF & _
" token" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"Should retrieve signIn" & @CRLF & _
"" & @CRLF & _
"mutation SendConfirmationEmail($athleteId: ID!) {" & @CRLF & _
" sendConfirmationEmail(athleteId: $athleteId) {" & @CRLF & _
" id" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"Should retrieve sendConfirmationEmail" & @CRLF & _
"" & @CRLF & _
"mutation CreateProgram($title: String!) {" & @CRLF & _
" createProgram(title: $title) {" & @CRLF & _
" id" & @CRLF & _
" title" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"Should retrieve createProgram" & @CRLF & _
"" & @CRLF & _
"query GetAllExerciseTemplates {" & @CRLF & _
" getAllExerciseTemplates {" & @CRLF & _
" id" & @CRLF & _
" title" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"Should retrieve getAllExerciseTemplates"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")